Willkommen, Gast
Benutzername: Passwort:
  • Seite:
  • 1

THEMA: JomSocial hängt eine stunde hinterher.

Aw: JomSocial hängt eine stunde hinterher. 09 Jan 2012 23:07 #1139

Bei mir gibt es die beiden Fehler nicht oder habe ich das was übersehen?
Das mit dem Calendar.setup hatte ich früher mal, so in der 1.8er Version, trat aber nur ab ud zu auf, seit dem eigentlich nicht mehr

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Bitte Fragen immer ins Forum posten, damit andere auch was von haben :-)

Aw: JomSocial hängt eine stunde hinterher. 09 Jan 2012 22:38 #1138

  • -Sam-
  • -Sam-s Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 49
  • Dank erhalten: 1
Hab jetzt mal das Joomla Default Template rein gemacht.

Zeigt mir folgenen Fehler an:

Calendar.setup:
Nothing to setup (no fields found). Please check your code

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: JomSocial hängt eine stunde hinterher. 09 Jan 2012 22:07 #1137

  • -Sam-
  • -Sam-s Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 49
  • Dank erhalten: 1
Schitt, denkste nix da, problem haben die auch diesmal nicht in griff bekommen, hat jemand die 2.6 Beta schon ausprobiert vielleicht haben die es ja da im griff

...nur nen fehler mehr, jetzt geht die gruppen ausgebe wieder nicht, ärger mich schon wieder

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von -Sam-.

Aw: JomSocial hängt eine stunde hinterher. 09 Jan 2012 21:59 #1136

  • -Sam-
  • -Sam-s Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 49
  • Dank erhalten: 1
Klasse, das hoffe ich, werde es gleich mal ausprobieren.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: JomSocial hängt eine stunde hinterher. 09 Jan 2012 20:44 #1133

Heute ist die Jomsocial Version 2.4.2 erschienen, vielleicht gehört der Fehler damit endlich der Vergangenheit an?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Bitte Fragen immer ins Forum posten, damit andere auch was von haben :-)

Aw: JomSocial hängt eine stunde hinterher. 09 Jan 2012 11:08 #1132

wenn du im Backend die Profilinfo öffnest, da stimmt komischerweise
die Zeit wieder. Bei mir fehlt lediglich in der Gesamtübersicht diese Stunde.
Da bin ich jetzt dran.

ps. der Fehler im Frontend tritt bei mir nicht auf. Bei mir wird immer der korrekte
Zeitunterschied angezeigt. Hab das jetzt mehrfach überprüft.
Hast du die neuesten Patsches von JS schon aufgespielt?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von Korpi.

Aw: JomSocial hängt eine stunde hinterher. 09 Jan 2012 10:23 #1129

  • -Sam-
  • -Sam-s Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 49
  • Dank erhalten: 1
Sorry, ändert aber nichts am eigentlichen problem.
Im Backend sowie im Frontend erscheint immer noch die falsche Zeit,
lediglich im Wallpost erscheint die richtige Zeit.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: JomSocial hängt eine stunde hinterher. 09 Jan 2012 08:38 #1128

den Fehler der 1 Stunde Zeitverschiebung in den Diskussions-Kommentaren
hab ich mit einem kleinen Trick behoben.
Habe bisher keine negativen Auswirkungen gesehen.

In "/components/com_community/libraries/" hab ich in der wall.php
die Zeile 362 folgendermaßen geändert.

$wall->created = (C_JOOMLA_15==1)?$date->toFormat( JText::_('DATE_FORMAT_LC2') ):$date->Format( JText::_('DATE_FORMAT_LC2') );

zu

$wall->created = (C_JOOMLA_15==0)?$date->toFormat( JText::_('DATE_FORMAT_LC2') ):$date->Format( JText::_('DATE_FORMAT_LC2') );

abgeändert.
Nun greift der Wall auf "Date_Format_LC2" zu.
Und da stimmt dann die Zeit.

gruß gerd

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: JomSocial hängt eine stunde hinterher. 07 Jan 2012 10:31 #1127

bei MyBlog habe ich festgestellt, das er sich das engl. Datumsformat aus Joomla holt.
Dort steht GMT. Für unsere Zeitzone müßte es GMT+1 sein.
Aber auf keinen Fall umscheiben...denn es stimmt dann wohl die Zeit im Blog,
aber es kommt dann in JomSocial einiges durcheinander.

Ich bleibe aber dran und werde das Ergebnis dann bekanntgeben.

Wünsche ein schönes Wochenende

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: JomSocial hängt eine stunde hinterher. 04 Jan 2012 17:29 #1110

das bringt hier nichts.

;) Ein Tip am Rande: Wer sein Datumsformat im ActivityStream auf fixed stehen hat oder es umstellen will,
kann das Format in der core.php ändern. ( Joomla 1.7 und JomSocial 2.4.1)

Der Pfad lautet: /components/com_community/libraries/core.php

Bei mir ist es die Zeile 806.


* To fix the date format when setting format is set to Fixed.
* This function retrieves the wrong format and set it to the correct one.
*/

if(C_JOOMLA_15==0){
$instance->_jparam->set('activitiesdayformat', 'F d');
ändern von: $instance->_jparam->set('activitiestimeformat', 'h:i A');


zu: $instance->_jparam->set('activitiestimeformat', '> l, d. M. Y - H:i:s');

Die Ausgabe im ActivityStream schaut dann so aus: > Mittwoch, 04. Jan. 2012 - 17:11:23

L.G. gerd

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von Korpi.

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 19:45 #1108

Mit einem
date_default_timezone_set('UTC');
direkt in der php-Datei hat es bei mir mal in einer anderen Komponente geholfen, die PMs eine Stunde zu früh geschrieben hat.
Kann aber auch nicht sein, dass man in php-Dateien rumwerkeln muss...

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Bitte Fragen immer ins Forum posten, damit andere auch was von haben :-)

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 19:35 #1107

die Beta hab ich ausprobiert....noch beschi.....

JS nimmt wirklich 2 verschiedene Zeiten.
Das merkt man erst, wenn man auf fixed stehen hat.

In der Konfiguration muß dann 0 stehen. Dann stimmt die Zeit fast überall.

Nur im Wallsystem (z.B. Kommentare in den Diskussionen hinkt die Zeit dann
eine Stunde hinterher)

Hab schon alle möglichen Zeitzonen ausprobiert.
Es ändert sich nichts.
Hatte auch schon mal JS angeschrieben, aber keine Reaktion.
Da bleibt nur Eigeninitiative....

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von Korpi.

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 19:17 #1105

Also irgendwie versteh ich die ganze Sache auch noch nicht so richtig, meine Serverzeit läuft richtig, Jomsocial nimmt die Zeit scheinbar nur teilweise aus der Konfiguration, andere Komponenten verwenden einen anderen Befehl und sind dann "1 Stunde früher". Warum nicht einfach die Serverzeit genommen wird, verstehe ich nicht so wirklich.
Scheint aber an unserer dummen Sommer-/Winterzeit zu liegen.

Übrigens gibt es seit heute eine MyBlog 2.3 Beta Version zu Downloaden ... ändert allerdings nix am Zeitproblem.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Bitte Fragen immer ins Forum posten, damit andere auch was von haben :-)

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 18:51 #1104

Hier sollte der Beitrag rein...

Wenn Ihr Zugriff auf die php.ini eures Servers habt probiert es mal mit folgendem Code aus:
[Date]
; Defines the default timezone used by the date functions
date.timezone= "Europe/Berlin"
date.default_latitude = 51.248532
date.default_longitude = 6.704677

Die zuständige php.ini findet Ihr im Joomlabackent raus:

Site==>Systeminformationen==>PHP-Informationen

eventuell geht es bei Eurem Server/Webspace auch über die .htaccess einfach mal danach googlen..

Desweiteren steht bei mir in der Joomla Konfiguration unter Server==>Serverzeitzone Berlin,
Jomsocial hat in der Konfiguration bei mir +1 Stunde zu stehen.

Gruß Thomy

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Bitte Fragen immer ins Forum posten, damit andere auch was von haben :-)

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 18:30 #1103

bei mir steht in der php.ini das drin:

Date
Defines the default timezone used by the date functions
date.timezone = "Europe/Berlin"

date.default_latitude = 31.7667
date.default_longitude = 35.2333

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 16:19 #1100

  • -Sam-
  • -Sam-s Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 49
  • Dank erhalten: 1
wenn ich nur wüsste in welcher php datei und zeile es versteckt ist das date_default_timezone_set()

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 15:56 #1099

glaube ich nicht.....

bei MyBlog 3.01 hat es noch gestimmt u. im neuen 3.1
verwenden sie das gleiche Format wie bei JS.
Schau mal bei deinem Blog nach.

Und bei anderen Komponenten stimmt es ja auch.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 15:53 #1098

  • -Sam-
  • -Sam-s Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 49
  • Dank erhalten: 1
Dachte schon wäre der einzige, hast du mal Knuddelesel gefragt, der hatte das Problem bestimmt auch, wir können ja mal auf ihn warten und schauen was er dazu sagt. Obwohl mir fällt gerade ein, er wird das problem garnicht haben, da er ja die orginal version verwendet nicht die eingedeutschte.

Schauen wa mal.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 15:50 #1097

Ist bestimmt nen Server Problem mit date_default_timezone_set ich find es nur nicht mehr, vielleicht könnt ihr es irgendwo in der Server-Konfiguration einstellen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Bitte Fragen immer ins Forum posten, damit andere auch was von haben :-)

Aw: JomSocial hängt eine stunde hinterher. 03 Jan 2012 15:42 #1096

das Problem besteht schon seit Version 1.8

Ich häng da auch schon dran. JS verwendet 2 verschiedene Datas.
Im Stream und auch im Gruppen-Stream stimmen die Zeiten.
Im Wall hingt die Zeit auch ne Stunde hinterher, obwohl
sie in den Aktivitäten richtig ist.
Habe auf fixed stehen und das Datumsformat auf deutsch angepasst.

In MyBlog 3.1 ist nun das gleiche.

Versuche schon seit Tagen das Prob zu lösen.
Ich gebe Bescheid...

Gruß gerd

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

JomSocial hängt eine stunde hinterher. 03 Jan 2012 15:18 #1095

  • -Sam-
  • -Sam-s Avatar Autor
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 49
  • Dank erhalten: 1
Kann mir jemand sagen, warum Jomsocial eine stunde hinterher hingt?

Ich schaue im Backend bei Benutzer im Joomla verzeichnis, da steht letzter login 14:30 Uhr und im JomSocial Benutzer steht bei den ein und den Selben User: letzter login 13:30 Uhr warum das, hab alles versucht denke ich auch das mit sommerzeit modus ect. nichts funtktioniert.

Da durch stimmt auch das Frontend nicht, auch wenn die letzte aktivität 1 sekunde her ist, zeigt es immer an: letzte aktivität vor 1 stunde und 1 sekunde.

Hat jemand ne IDEE? Thx

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
Ladezeit der Seite: 0.187 Sekunden
Powered by Kunena Forum
Follow